If you are using an old version of the game, you can download a version of the mod that is compatible with the game version you are using from below.

Download Links

Version: 6.0

Supported ETS 2 versions: 1.35.X - 1.36.X

Version: 5.8

Supported ETS 2 versions: 1.33.X - 1.34.X - 1.35.X

Version: 5.7

Supported ETS 2 versions: 1.32.X

Version: 5.6

Supported ETS 2 versions: 1.31.X

Version: 5.4

Supported ETS 2 versions: 1.30.X

Version: 5.2

Supported ETS 2 versions: 1.29.X

Version: 5.1

Supported ETS 2 versions: 1.28.X

Version: 4.5

Supported ETS 2 versions: 1.27.X

Version: 3.1

Supported ETS 2 versions: Between 1.15.X and 1.27.X

Version: 2.0

Supported ETS 2 versions: Between 1.7.X and 1.15.X